Thursday, October 19, 2017

Cisco WLC/Mobility Express (Air-AP1850 series AP) Configuration and Preparing APs to Associate with the WLC AP




######################## Cisco L3 Switch Ports configuration ###########################
Switch(config)#vlan 99
Switch(config-vlan)#name MGT_WLC
Switch(config)#vlan 151
Switch(config-vlan)#name WiFi_Vlan151_Employee

Switch(config)#vlan 152
Switch(config-vlan)#name WiFi_Vlan152_Guest

Switch(config)#interface vlan 99
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan99, changed state to up
Switch(config-if)#ip address 192.168.99.1 255.255.255.0

Switch(config)#interface vlan 151
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan151, changed state to up
Switch(config-if)#ip address 192.168.151.1 255.255.255.0

Switch(config)#interface vlan 152
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan152, changed state to up
Switch(config-if)#ip address 192.168.152.1 255.255.255.0

Switch(config)#ip dhcp pool MGT_WLC_AP
Switch(dhcp-config)#network 192.168.99.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.99.1

Switch(config)#ip dhcp pool WiFi_Vlan151_cilent
Switch(dhcp-config)#network 192.168.151.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.151.1

Switch(config)#ip dhcp pool WiFi_L7_client
Switch(dhcp-config)#network 192.168.152.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.152.1


Switch(config)#interface fa0/1
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk native vlan 99
Switch(config-if)#switchport trunk allowed vlan 99,151,152

Switch(config)#interface fa0/2
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk native vlan 99
Switch(config-if)#switchport trunk allowed vlan 99,151,152

Switch(config)#interface fa0/3
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk native vlan 99
Switch(config-if)#switchport trunk allowed vlan 99,151,152

N.B. For Cisco, all ports must have to be trunk and must have to use native vlan for management. Allow all vlan for the trunk port including MGT vlan.
For Juniper, All ports must have to be trunk and must have to use native vlan for management. Allow all vlan for the trunk port excluding MGT vlan.

####################### WLC-AP (Air-AP1850) configuration #######################

APs are two types. One is Mobility express/standalone device which can be a wireless lan controller (WLC) with an access point (AP) and other type is only access point (AP).


Before start, we have to reset the WLC-AP (Air-AP1850) and connect the WLC-AP with Laptop by console cable .

1. Therefore, press on the reset button of the WLC-AP (Air-AP1852i) and then connect wlc-ap to fa0/1 trunk port of Cisco L3 switch. Press the button for 25 sec then it will reset.

2. When reset completed, the following step should be completed accordingly.

Starting the Initial Configuration Wizard

(Cisco Controller)
Cisco Aironet 1850 Series Mobility Express
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
Would you like to terminate autoinstall? [yes]: yes
Enter Administrative User Name (24 characters max): root
Enter Administrative Password (3 to 24 characters)   : abc12345
Re-enter Administrative Password                                 : ********
System Name [Cisco_1a:62:20] (31 characters max): WLC_Demo
Enter Country Code list (enter 'help' for a list of countries) [US]: help
Enter the country code list (e.g. US,CA,MX) max=30.
Supported Country Codes:
AE, AL, AR, AT, AU, BA, BB, BE, BG, BH, BM, BN, BO,
BR, BY, CA, CH, CL, CM, CN, CO, CR, CY, CZ, DE, DK,
DO, DZ, EC, EE, EG, EL, ES, FI, FJ, FR, GB, GH, GI,
GR, HK, HR, HU, ID, IE, IL, IO, IN, IQ, IS, IT, J4,
JM, JO, KE, KN, KW, KZ, LB, LI, LK, LT, LU, LV, LY,
MA, MC, ME, MK, MN, MO, MT, MX, MY, NG, NL, NO, NZ,
OM, PA, PE, PH, PK, PL, PR, PT, PY, QA, RO, RS, RU,
SA, SE, SG, SI, SK, TH, TI, TN, TR, TW, UA, US, UY,
VE, VN, ZA
Enter Country Code list (enter 'help' for a list of countries) [US]: CN
Configure a NTP server now? [YES][no]: no
Configure the system time now? [YES][no]: yes
Enter the date in MM/DD/YY format: 10/18/17
Enter the time in HH:MM:SS format: 14:04:00
Enter timezone location index (enter 'help' for a list of timezones): help
  1. (GMT-12:00) International Date Line
  2. (GMT-11:00) Samoa                   3. (GMT-10:00) Hawaii
  4. (GMT -9:00) Alaska     5. (GMT -8:00) Pacific Time
  6. (GMT -7:00) Mountain Time   7. (GMT -6:00) Central Time
  8. (GMT -5:00) Eastern Time        9. (GMT -4:00) Altantic Time
 10. (GMT -3:00) Buenos Aires     11. (GMT -2:00) Mid-Atlantic
 12. (GMT -1:00) Azores                  13. (GMT) London, Lisbon, Dublin
 14. (GMT +1:00) Amsterdam,Berlin,Rome            15. (GMT +2:00) Jerusalem
 16. (GMT +3:00) Baghdad                             17. (GMT +4:00) Muscat, Abu Dhabi
 18. (GMT +4:30) Kabul                                   19. (GMT +5:00) Karachi, Tashkent
 20. (GMT +5:30) Colombo, New Delhi     21. (GMT +5:45) Kathmandu
 22. (GMT +6:00) Almaty, Novosibirsk      23. (GMT +6:30) Rangoon
 24. (GMT +7:00) Hanoi, Bangkok               25. (GMT +8:00) HongKong, Beijing
 26. (GMT +9:00) Tokyo, Osaka, Seoul      27. (GMT +9:30) Darwin
 28. (GMT+10:00) Sydney, Melbourne     29. (GMT+11:00) Solomon Is.
 30. (GMT+12:00) Auckland, Fiji
Enter timezone location index (enter 'help' for a list of timezones): 22
Management Interface IP Address Configuration [STATIC][dhcp]: STATIC
Management Interface IP Address: 192.168.99.25
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.99.1
Cleaning up Provisioning SSID

Create Management DHCP Scope? [yes][NO]: no
Employee Network Name (SSID)?: Employee_demo
Employee Network Security? [PSK][enterprise]: psk
Employee PSK Passphrase (8-63 characters)? : 12345678
Re-enter Employee PSK Passphrase                 : 12345678
Enable RF Parameter Optimization? [YES][no]: yes
Client Density [TYPICAL][Low][High]:
Traffic with Voice [NO][Yes]: yes
Configuration correct? If yes, system will save it and reset. [yes][NO]: yes

Cleaning up Provisioning SSID
Configuration saved!
Resetting system with new configuration...

Then system will reboot.

3.Connect to the wifi which SSID is "Employee_demo". Open the browser and write down the
address "https://192.168.99.25". After that login to the WLC with the username (root) & password "abc12345" which was given earlier.

Logging in to Cisco Mobility Express (ME)





















4.




Understanding the Mobility Express(ME) Controller Web Interface


No.
Web Interface Section or Feature
1
The side pane of the web interface. This is main navigational pane using which you can navigate to the various sub-sections in the web interface.
2
The title of the web interface. It indicates the AP model of the master AP (on which the integrated controller functionality is currently operating)
3
Search for an AP or client using its MAC address.
4
Click to save the current controller configuration to the NVRAM.
5
Click to view the current system information or to log off the controller web interface.
6
The Mobility Express Network Monitoring section.
7
The Wireless Settings section, where you can administer associated APs, manage WLANs, WLAN user accounts, and guest user accounts.
8
The Management section, where you can set management access parameters, manage admin accounts, network time, and perform software updates.
9
The Advanced section, where you can set SNMP settings, sys log settings, and perform a reset to factory default.

4. From the web Panel go to Wireless Settings>>Add new WLAN and do accordingly to the following snapshots.





5. After that we will join another AP to the WLC. Therefore, connect another AP (Air-AP1850) to the switch port fa0/2 and wait for a while. Then check on the WLC web panel and you will see the second AP has been joined.

















Reference Links:
https://www.cisco.com/c/en/us/td/docs/wireless/access_point/mob_exp/1/user_guide/b_ME_User_Guide/getg_start.html