Monday, March 16, 2020

OSPF Over GRE Tunnel



Site-A(Mikrotik Router):

/interface gre
add !keepalive local-address=10.29.122.66 mtu=1400 name=GRE-Borak-banasree-L3-DATA remote-address=220.220.220.92

/ip address
add address=10.29.122.66/30 interface=ether2 network=10.29.122.64
add address=192.168.2.1/24 interface=ether3 network=192.168.2.0
add address=172.16.1.2/30 interface=GRE-Borak-banasree-L3-DATA network=172.16.1.0

/ip route
add distance=1 gateway=10.29.122.65

/routing ospf interface
add interface=ether3 network-type=broadcast passive=yes
add authentication=md5 authentication-key=abc authentication-key-id=113 interface=GRE-Borak-banasree-L3-DATA network-type=point-to-point

/routing ospf network
add area=backbone network=172.16.1.0/30
add area=backbone network=192.168.2.0/24


Site-B(Mikrotik Router):

/interface gre
add !keepalive local-address=220.220.220.92 mtu=1400 name=GRE-Borak-banasree-L3-DATA remote-address=10.29.122.66

/ip address
add address=220.220.220.92/29 interface=ether1 network=220.220.220.88
add address=192.168.1.1/24 interface=ether2 network=192.168.1.0
add address=172.16.1.1/30 interface=GRE-Borak-banasree-L3-DATA network=172.16.1.0

/ip route
add distance=1 gateway=220.220.220.89


/routing ospf interface
add interface=ether2 network-type=broadcast passive=yes
add authentication=md5 authentication-key=abc authentication-key-id=113 interface=GRE-Borak-banasree-L3-DATA network-type=point-to-point

/routing ospf network
add area=backbone network=172.16.1.0/30
add area=backbone network=192.168.1.0/24

Borak(Mikrotik Router):

/ip address
add address=220.220.220.89/29 interface=ether1 network=220.220.220.88
add address=10.29.122.65/30 interface=ether2 network=10.29.122.64

PC1:

PC1> ip 192.168.1.2 255.255.255.0 192.168.1.1

PC2:

PC2> ip 192.168.2.2 255.255.255.0 192.168.2.1